Gitaar.net

 
Wachtwoord kwijt?    Nog geen lid?
Forum: Vragen en opmerkingen
berichtWachtwoord
Gepost door: Marius
Datum: 13/07/2007 19:32

Het lijkt er op dat een wachtwoord aanpassen met speciale tekens niet werkt.

( en -

Neem aan dat het niet hoofdletter gevoelig is.

Zou je hier naar willen kijken, kan ik me wachtwoord veranderen tandpastagrijns

Marius van Witzenburg
[www.kitara.nl]
berichtRe: Wachtwoord
Gepost door: Maurice Makaay
Datum: 13/07/2007 21:07

Ja, ga ik uitzoeken.

--
Maurice Makaay
Gitaar.net webmaster, Phorum hacker, gitarist
berichtRe: Wachtwoord
Gepost door: Maurice Makaay
Datum: 13/07/2007 21:13

Ik heb er zelf geen problemen mee. Ik heb mijn eigen wachtwoord gewijzigd naar "(-cool". Daarna uitgelogd en ingelogd met dat wachtwoord. Vervolgens dat wachtwoord weer naar mijn eigen oude wachtwoord gewijzigd. Uitgelogd, ingelogd, allemaal goed.

Krijg je nog een mooie foutmelding of zo?

--
Maurice Makaay
Gitaar.net webmaster, Phorum hacker, gitarist
berichtRe: Wachtwoord
Gepost door: Marius
Datum: 14/07/2007 14:58

Standaard melding:

En of meer problemen gevonden:
Je huidige wachtwoord is niet juist ingevuld


Een bijkoment ding, ik gebruik een mac en die is wat stricter in het versturen van data en quote niets voor je zegmaar knipoog

Zo zijn er ook bepaalde dingen in de layout die op safari/FF niet netjes over komen... Weet niet of je AOL/MSN/ICQ/Yahoo hebt kan je me pass wel krijgen om het even te checken gezien ik dat pass toch nergens anders gebruik dan hier en kan ik je wat screenshots sturen hoe bepaalde dingen er uit zien omdat ze niet geheel browser compatible zijn blij

Marius van Witzenburg
[www.kitara.nl]
berichtRe: Wachtwoord
Gepost door: Maurice Makaay
Datum: 14/07/2007 21:38

Ik heb geen IM. Maar je kunt me via deze site wel een PM sturen. Het niet quoten (ik neem aan dat je urlencoden bedoelt) van informatie hoort geen probleem te zijn.

--
Maurice Makaay
Gitaar.net webmaster, Phorum hacker, gitarist
berichtRe: Wachtwoord
Gepost door: Maurice Makaay
Datum: 14/07/2007 23:41

Ik krijg het echt niet nagebootst. Die karakters zijn niet zo heel speciaal en ik kan daarmee gewoon wachtwoorden maken en aanpassen.

--
Maurice Makaay
Gitaar.net webmaster, Phorum hacker, gitarist
berichtRe: Wachtwoord
Gepost door: Marius
Datum: 15/07/2007 02:19

enctype="multipart/form-data"

Ik zou dat even weghalen bij het from blij

Grote kans dat het dan wel goed is, multipart/form-data gebruik je over het algemeen alleen als je ook files tegelijk moet sturen.

Gezien je zonder die enctype default naar: application/x-www-form-urlencoded

Marius van Witzenburg
[www.kitara.nl]
berichtRe: Wachtwoord
Gepost door: Maurice Makaay
Datum: 15/07/2007 02:47

Als dat zo werkt, dan is dat IMO een bug in je browser. Meestal wordt multipart form gebruikt in combinatie met file uploads, maar het hoeft niet. De beschrijving is: "The content type "multipart/form-data" should be used for submitting forms that contain files, non-ASCII data, and binary data.". Ik heb het binnen die beschrijving altijd al gebruikt in verschillende formulieren, ook zonder combinatie met een file upload.

Wat zou er trouwens gebeuren als je wel een file upload in dat scherm zou hebben? Dan moet de browser toch ook in staat zijn de formuliervelden zinnig te versturen?

De reden dat het in het profiel scherm wordt gebruikt, is dat ik daar steeds dezelfde formuliercode gebruik. Alleen de inhoud van het formulier wijzigt. Maar goed, omdat het toch moet worden opgelost, heb ik de code van de profielpagina gewijzigd. Multipart MIME encoding wordt nu alleen nog op de afbeeldingen pagina toegepast.

Kijk maar eens of het nu wel voor je werkt.

--
Maurice Makaay
Gitaar.net webmaster, Phorum hacker, gitarist
berichtRe: Wachtwoord
Gepost door: Marius
Datum: 15/07/2007 03:25

Dat lost het niet op, het gaat dus ergens fout na de submit.

Bug in m'n browser is het niet om verschillende redenen:
- meerdere browsers
- gitaar.net is de enige uit 49 sites die het probleem geeft
- safari werkt volgens webstandaarden en wijkt er niet mee af (zoals bijv IE doet)

Maar als je zegt dat het wel werkt van een Win (latin1) OS dan zou het probleem zitten in de Mac (UTF8) wijze hoe het verzonden word, dit zou dan simpelweg betekenen dat elk UTF8 OS hier problemen mee zal krijgen...

Ik durf namelijk te wedden als ik onder windows het zelfde probeer dat het werkt, gezien die het met Latin1 encoding verstuurd ipv UTF8

Enige manier om dit te ondervangen is 100% zeker er van zijn dat je data in je database uit UTF8 code bestaat (encoding/decoding) dit is overigens voor internationaal gebruik zeker aan te raden, gezien je met andere talen zeker onderuit gaat gezien de speciale caracters...

Kan jij mij voorzien van een .sql file met de query die een inert uitvoert hoe mijn wachtwoord nu exact in jou DB staat?

Makkelijker gezien het via 't forum 3x nix is om deze dingen uit te zoeken....
Mail het maar naar: marius@kitara.nl

Marius van Witzenburg
[www.kitara.nl]
berichtRe: Wachtwoord
Gepost door: Maurice Makaay
Datum: 15/07/2007 03:47

Gitaar.net is niet internationaal en gebruikt niet UTF-8, maar Latin-1 als karakterset. Ik mag hopen dat je browser snapt dat deze geen UTF-8 data opstuurt, maar Latin-1, omdata de site aan alle kanten uitschreeuwt Latin-1 te coderen.

Je wachtwoord bestaat overigens uit ASCII tekens, dus zelfs al zou je browser spelen met de codering, dan nog zuden die tekens het moeten overleven volgens mij.

Het beste lijkt me om precies te loggen wat je browser opstuurt en wat PHP ervan maakt voordat ik het in mijn script krijg. Ik zal iets van logging inbouwen en je per mail laten weten wat er verder moet om te testen.

--
Maurice Makaay
Gitaar.net webmaster, Phorum hacker, gitarist
berichtRe: Wachtwoord
Gepost door: Maurice Makaay
Datum: 15/07/2007 03:58

Nog even wat nagelezen voor de zekerheid om te zien of ik het me goed herinnerde. Uit de standaarden die Safari op de letter volgt: het accept-charsete attribuut van <form>:

Quote:
accept-charset = charset list [CI]
[..]
The default value for this attribute is the reserved string
"UNKNOWN". User agents may interpret this value as the character
encoding that was used to transmit the document containing this
FORM element.

Daar lees is uit dat zonder accept-charset attribuut, de browser het beste de charset van het document aan zou kunnen houden. Om te testen, heb ik nu een specifieke accept-charset aan de formulieren toegevoegd. Probeer voor de gein eens of dat verschil heeft gemaakt.

--
Maurice Makaay
Gitaar.net webmaster, Phorum hacker, gitarist
berichtRe: Wachtwoord
Gepost door: Marius
Datum: 15/07/2007 11:35

Werkt niet...

Overigens, default pakt mijn safari op Mac OS X 10.4.10 UTF8 indien niets is opgegegeven.
Dit is factory-default vanuit apple...

Zal wel ff wat data loggen om je te sturen...

*edit*
Mail vanaf nu overigens, forum is echt serieus 10x kut
*/edit*

Marius van Witzenburg
[www.kitara.nl]



4 keer gewijzigd. Laatste wijziging: 15/07/2007 11:40 door Marius.
top

Bericht
Sorry, alleen geregistreerde gebruikers mogen berichten plaatsen in dit forum.

Klik hier om in te loggen